Repost: Disable High Gain Mode

Home Forums Hardware Freakduino Repost: Disable High Gain Mode

This topic contains 1 reply, has 1 voice, and was last updated by  akiba September 4, 2017 at 5:37 am.

  • Author
    Posts
  • #408

    akiba
    Keymaster

    [Reposted from the old forum]
    I’m trying to disable the high gain mode and I have this error when compiling program:
    C:\Program Files (x86)\Arduino\libraries\chibiarduino_v1.06/chibi.cpp:404: undefined reference to `chb_high_gain_mode_disable()’
    I chase the Freakduino board in the Arduino IDE and all the settings seems to be ok.
    What can be the problem?

    • This topic was modified 1 year, 5 months ago by  akiba.
    • This topic was modified 1 year, 5 months ago by  akiba.

    Akiba
    FreakLabs Open Source Wireless
    Twitter: @freaklabs
    Facebook: https://www.facebook.com/freaklabswireless

  • #410

    akiba
    Keymaster

    It’s likely your board setting is incorrect. You need to have the board setting to one of the long range boards, otherwise, the high_gain_mode_disable function won’t be defined, ie: there is no high gain mode.

    Akiba
    FreakLabs Open Source Wireless
    Twitter: @freaklabs
    Facebook: https://www.facebook.com/freaklabswireless

You must be logged in to reply to this topic.